DCSNetwork Switch Configuration Triple Vlan Split DLink DGS1510


Introduction

The objective is to configure a network switch, D-Link DGS 1510-28 L3 switch with 24 RJ45 + 4 SFP ports to provide 3 independent access blocks of ports serving 3 different VLANs.
Two modes are foreseen:
  1. 3 blocks of 7+1 ports with each having a separate uplink to an untagged access port of the next higher network switch
    • 3 up-links
      D-link-front-3-vlan-3uplink.png
  2. 3 blocks of 8 ports served by a common VLAN ID tagged uplink SFP/RJ45 to an trunk port of the next higher network switch
    • requires configuration of the next higher switch, maybe administrated by others
    • 1 up-link:
      D-link-front-3-vlan-1uplink.png


Implementation


Documentation


Preparatory Work


Connecting the switch

Starting from scratch the factory settings offer an ip connection on IP 10.90.90.90/8 (255.0.0.0) on interface vlan1 at every port of the switch. If you have a PC with a suitable network setting skip Configuring the IP Address


Configuring the IP Address

Connection via Console Port

To connect directly to the switch we use the Console Port of the switch and the special Console Cable (RJ-45 to RS-232) .
  1. Connect the RS-232 end of the console cable to the Serial Port of the management PC or an RS-232 to Ethernet Comport
  2. Connect the RJ-45 end of the console cable to the Console Port of the Switch.
  3. Configure a terminal emulation program on the management PC or or the comport settings to have
    • 115200 baud, 8N1,no flow control
  4. connect to switch
  5. login: admin/(same as username) (default)


Command Line Interface (CLI): ip address
  1. enter the following command sequence:
Switch> enable
Switch# configure terminal
Switch(config)# interface vlan 1
Switch(config-if)# ip address 192.168.1.1 255.255.255.0
Switch(config-if)# exit






Connect via Web-based User Interface

  • Use a browser to connect to the (pre/above ) defined IP
    • Login: admin/(same password as username)




3 up-links

D-link-front-3-vlan-3uplink.png
  • assume port 1 connected for the management

create additional (independent) VLANs

  1. Descend the directory:
    • L2 FeaturesVLAN802.1Q VLAN
  2. Configure for each VLAN (block) a new VID:
    1. VID List e.g. : 111,222,333
    2. Apply
    3. optionally edit VLAN Name
    4. Save configuration

VLAN-802.1Q.PNG



set-up VLAN Interface

  1. Descend the directory:
    • L2 FeaturesVLANVLAN Interface
  2. Edit (and Clone) each VLAN Interface Port Configuration:
    port vlan ID (VID) description VLAN Mode Acceptable Frame Type Ingress Checking Enabled
    1 1 management - DO NOT CHANGE Hybrid (Native LAN) Admit All yes
    2-8 111 (HADES) ACCESS Untagged Only yes
    9-16 222 (GSI) ACCESS Untagged Only yes
    17-24 333 (IPMI) ACCESS Untagged Only yes
    25-28 1 (default settings/ not used) Hybrid (Native LAN) Admit All yes
  3. Save configuration


Intermediate Configuration, only one up-link connected



Final Configuration


... via Configuration File

  1. Download this configuration file
  2. optionally modify VIDs
  3. Use Configuration Restore & Backup to pload configuration file:
    Configuration_Restore__Backup.PNG
  4. Save configuration


... from Scratch via Console
  1. open console connection (see chapter ... )
  2. deactivate ip settings for default VLAN vlan1 no ip address
    and set ip address for vlan111
    haddcssw01(config)#interface vlan 1
    haddcssw01(config-if)#no ip address 192.168.100.201 255.255.252.0
    haddcssw01(config-if)#exit
    haddcssw01(config)#interface vlan 111
    haddcssw01(config-if)#ip address 192.168.100.201 255.255.252.0
    haddcssw01(config-if)#exit
    haddcssw01(config)#end
  3. switch configuration of port 1 to from vlan1 to vlan111 and change mode to access
    haddcssw01(config)#interface ethernet 1/0/1
    haddcssw01(config-if)#switchport mode access
    haddcssw01(config-if)#switchport access vlan 111
    haddcssw01(config-if)#end






1 up-link

D-link-front-3-vlan-1uplink.png

NOTE:



-- PeterZumbruch - 26 Sep 2017
-- PeterZumbruch - 27 Sep 2017
Topic attachments
I Attachment Action Size Date Who Comment
Configuration_Restore__Backup.PNGPNG Configuration_Restore__Backup.PNG manage 13.0 K 21 Sep 2017 - 13:05 PeterZumbruch Configuration Restore & Backup Dialog
D-link-front-3-vlan-1uplink.pngpng D-link-front-3-vlan-1uplink.png manage 195.9 K 21 Sep 2017 - 10:24 PeterZumbruch 1uplink
D-link-front-3-vlan-3uplink.pngpng D-link-front-3-vlan-3uplink.png manage 198.1 K 21 Sep 2017 - 10:23 PeterZumbruch 3uplink
DGS-1510-20_man-CLI_RevA_1-30_all_en_20151028.pdfpdf DGS-1510-20_man-CLI_RevA_1-30_all_en_20151028.pdf manage 5273.3 K 21 Sep 2017 - 08:50 PeterZumbruch Local copy of Command Line Interface
ftp://ftp.dlink.de/dgs/dgs-1510-20/documentation/DGS-1510-20_man-CLI_RevA_1-30_all_en_20151028.pdf
DGS-1510-20_man_RevA_1-30_all_en_20151028.pdfpdf DGS-1510-20_man_RevA_1-30_all_en_20151028.pdf manage 11319.2 K 21 Sep 2017 - 08:52 PeterZumbruch Local copy of Web UI Reference Guide
ftp://ftp.dlink.de/dgs/dgs-1510-20/documentation/DGS-1510-20_man_RevA_1-30_all_en_20151028.pdf
DGS-1510_Series_HW_Installation_Guide_1-30.pdfpdf DGS-1510_Series_HW_Installation_Guide_1-30.pdf manage 3443.3 K 21 Sep 2017 - 08:54 PeterZumbruch Local copy of Hardware Installation Guide
ftp://ftp.dlink.de/dgs/dgs-1510-20/documentation/DGS-1510_Series_HW_Installation_Guide_1-30.pdf
HADES_GIFFWSX24_VLAN_tagged_Trunk_SFP_port_für_GSI,_HADES,_IPMI.pdfpdf HADES_GIFFWSX24_VLAN_tagged_Trunk_SFP_port_für_GSI,_HADES,_IPMI.pdf manage 51.3 K 27 Sep 2017 - 09:31 PeterZumbruch mail correspondance with GSI-network group
VLAN-802.1Q.PNGPNG VLAN-802.1Q.PNG manage 41.0 K 21 Sep 2017 - 12:25 PeterZumbruch VLAN Configuration
haddcssw01-running-config_19.09.2017-10-08.cfgcfg haddcssw01-running-config_19.09.2017-10-08.cfg manage 37.9 K 21 Sep 2017 - 12:56 PeterZumbruch dlink configuration file - 3 uplinks via 3 vlans + 1 management vlan (1)
haddcssw01-running-config_19.09.2017-10-46_3vlan.cfgcfg haddcssw01-running-config_19.09.2017-10-46_3vlan.cfg manage 38.0 K 21 Sep 2017 - 12:57 PeterZumbruch dlink configuration file - 3 uplinks via 3 vlans
Topic revision: r6 - 27 Sep 2017, PeterZumbruch
 
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Hades Wiki? Send feedback
Imprint (in German)
Privacy Policy (in German)